Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: Firefox / Addons

  1. #1
    High Priestess of The Classics Jenny's Avatar
    Join Date
    Dec 2012
    Location
    Here and there....
    Posts
    1,701
    Thanks
    24,056
    Thanked 10,591 Times in 1,704 Posts

    Thumbs up Firefox / Addons

    All addons stoppred working and were disabled. It's a certificate problem on their end.

    I am subscribed to get an update when they fix it so I will let you know.

    sig courtesy of B.Bubba

  2. The Following 10 Users Say Thank You to Jenny For This Useful Post:


  3. #2
    Persephone's Avatar
    Join Date
    Dec 2012
    Posts
    266
    Thanks
    5,170
    Thanked 2,951 Times in 266 Posts
    Just coming here to vent. WTF, Firefox? How does one certificate lapsing like that revoke everything to do with add-ons, themes, etc. with no warning?

  4. The Following 9 Users Say Thank You to Persephone For This Useful Post:


  5. #3
    Toot toot, hey, beep beep Frosty's Avatar
    Join Date
    Dec 2012
    Location
    Strawberry Fields
    Posts
    10,989
    Thanks
    55,447
    Thanked 50,673 Times in 10,450 Posts
    I don't seem to be having any issues with anything.
    My HEVC/H.265/x265 videos can be played with either VLC or MPC-HC



    Apathy their stepping stone, so unfeeling...
    Hidden deep animosity, so deceiving...
    Through your eyes their light burns, hoping to find...
    Inquisition sinking you with prying minds..

  6. The Following 7 Users Say Thank You to Frosty For This Useful Post:


  7. #4
    Elite B-Force's Avatar
    Join Date
    Dec 2012
    Posts
    380
    Thanks
    1,381
    Thanked 2,617 Times in 374 Posts
    This morning everything was alright. Couple hours later every Addon AND Theme automatically deactivated. Very bad!

  8. The Following 6 Users Say Thank You to B-Force For This Useful Post:


  9. #5
    No Time To Die BondJmsBond's Avatar
    Join Date
    Dec 2012
    Posts
    2,630
    Thanks
    16,377
    Thanked 14,136 Times in 2,629 Posts
    Hopefully it's fixed soon. Firefox suddenly doing this made me think I had a virus and do a series of AV scans. Also now I know how much I miss UBlock, these ads suck.

    I like how Firefox tries to blame us by default. "Your outdated add-ons..."


    *I read you can temp fix this by setting your system clock to before this happened, but I'm not going to do that. With my luck it would trap me in the past forever.
    Last edited by BondJmsBond; 05-04-2019 at 07:17 AM.

  10. The Following 8 Users Say Thank You to BondJmsBond For This Useful Post:


  11. #6
    ಠ_ಠ defrabbit's Avatar
    Join Date
    Dec 2012
    Posts
    7,846
    Thanks
    19,197
    Thanked 66,546 Times in 7,839 Posts
    I use firefox ESR and only had two add-ons (out of about 8) disabled. I looked
    it up and it said (for ESR) you can disable requiring signed add-ons in about:config

  12. The Following 7 Users Say Thank You to defrabbit For This Useful Post:


  13. #7
    High Priestess of The Classics Jenny's Avatar
    Join Date
    Dec 2012
    Location
    Here and there....
    Posts
    1,701
    Thanks
    24,056
    Thanked 10,591 Times in 1,704 Posts
    Response from Mozilla:



    Mozilla has rolled-out a fix for this. The fix will be automatically applied in the background within the next few hours, you don’t need to take active steps.

    In order to be able to provide this fix on short notice, they are using the Studies system. You can check if you have studies enabled

    Go to [=] > Options > Privacy & Security.
    Make sure Allow Firefox to install and run studies is check marked.

    I you had it disabled, you can disable studies again after your add-ons have been re-enabled.

    They are working on a general fix that doesn't need to rely on this and will keep you updated.

    sig courtesy of B.Bubba

  14. The Following 9 Users Say Thank You to Jenny For This Useful Post:


  15. #8
    No Time To Die BondJmsBond's Avatar
    Join Date
    Dec 2012
    Posts
    2,630
    Thanks
    16,377
    Thanked 14,136 Times in 2,629 Posts
    Thank you Jenny, that worked just fine for me

  16. The Following 8 Users Say Thank You to BondJmsBond For This Useful Post:


  17. #9
    Diva wildwest08's Avatar
    Join Date
    Dec 2012
    Posts
    3,321
    Thanks
    14,284
    Thanked 17,078 Times in 3,309 Posts

    Question

    ok, just checked, "studies" has always been allowed

    still nothing though

    Question

    after thinking an update to the latest FF version 66.0.3 would help,
    it didn't obviously

    didn't like the way the page format looked, so we thought going back to
    defaults would help

    it's more of a mess

    so far we still have most of their sites and log ins with FF, so that's something

    we were running 56 for a long time before, thought that was the issue originally (wasn't)

    SO

    what about using System Restore, at least we can go back to that earlier version of 56 (we think, not sure)

    then we can update online to latest version, and hopefully not have the "style" format issue (completely
    different than what we're used to, no help tab on top, etc

    Jen, any thoughts please

  18. The Following 8 Users Say Thank You to wildwest08 For This Useful Post:


  19. #10
    Persephone's Avatar
    Join Date
    Dec 2012
    Posts
    266
    Thanks
    5,170
    Thanked 2,951 Times in 266 Posts
    Quote Originally Posted by wildwest08 View Post
    ok, just checked, "studies" has always been allowed

    still nothing though

    Question

    after thinking an update to the latest FF version 66.0.3 would help,
    it didn't obviously

    didn't like the way the page format looked, so we thought going back to
    defaults would help

    it's more of a mess

    so far we still have most of their sites and log ins with FF, so that's something

    we were running 56 for a long time before, thought that was the issue originally (wasn't)

    SO

    what about using System Restore, at least we can go back to that earlier version of 56 (we think, not sure)

    then we can update online to latest version, and hopefully not have the "style" format issue (completely
    different than what we're used to, no help tab on top, etc

    Jen, any thoughts please
    The only way to prevent a certificate lapse like this is to run the FF ESR/Nightly/Developer builds, as those have options to disable the "extension signing" part that caused so much mass chaos. No such overrides exist in the Release or Beta versions starting with FF 48. Or you could possibly fork Firefox, but then you'd have to do upkeep on the latest changes.

    Edit: https://wiki.mozilla.org/Add-ons/Extension_Signing has all the details. You can opt for "unbranded FF."

  20. The Following 6 Users Say Thank You to Persephone For This Useful Post:


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •